Users experiencing issue in logging into the Domotz service
Incident Report for Domotz
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 07:11 UTC
Investigating
We are currently investigating this issue.
Posted Jul 17, 2024 - 00:01 UTC
This incident affected: Domotz Pro Service (Authentication - North America).