Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 07:30 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Mar 17, 2025 - 15:14 UTC
This scheduled maintenance affected: Domotz Service (Authentication - North America (US), Authentication - Rest of World, Collector Activation - North America (US), Collector Activation - Rest of the World).